System Error on Single Player World Creation

DelakDelak REGISTERED Posts: 7 Podling
Hello I just got this game for my son and myself. For my son he is getting the following error when click on New World from the single player option

Any help on resolving this would be great. I am sure you will need more information just let me know and I will get.

Thank you


  • CobellCobell REGISTERED Posts: 84
    edited May 2015
    We'll investigate. Are you running any other games or services on that PC by any chance? Like another instance of TUG or a server that is using UDP Port 6600?

    In the meantime, the following should work:
    1) Go ahead and just have him launch a Multiplayer game
    2) If you get the same error change the UDP Port number to any other value like say 6601.

    Single Player I believe is just using a default value of 6600 (and just doesn't allow any other players to connect to that game).

    Multiplayer and Single Player are otherwise functionally no different except for pausing the game when you enter the menus in Single Player.
  • DelakDelak REGISTERED Posts: 7 Podling
    Hello Cobell, thank you for the reply.

    I dont think there is another game or service running on the pc that would use the same port. I will check if another instance of TUG is running.

    I have tried to change the UDP port to 6601 as my first troubleshooting step and that didnt seem to work.

    I will let you know the results of checking to see another instance of TUG is running. I may have him just reboot it the pc.

  • DelakDelak REGISTERED Posts: 7 Podling
    No luck with the reboot. Will check if other things are running on that port.

    Any other suggestions and/or information (logs) that I can post here.
  • SimbaSimba REGISTERED, Developers Posts: 74 Developer
    Can you try other ports besides 660x? Anything from 1025 to 49000. If you have no luck then you must have something on that computer blocking TUG from opening a port.

    Unfortunately, for now, the game will create a listening socket and connect to itself. This was done to get multiplayer out sooner while maintaining a stable single player, and up until now hasn't been an issue. Your problem may warrant more looking into it, but we need to know for sure that it's not just a port collision.
  • DelakDelak REGISTERED Posts: 7 Podling
    Okay we have tried the following ports 3301 and 11203. I will check to see if I can find anything that might be blocking a port but I am not sure what it could be. I will keep you all posted.
  • DelakDelak REGISTERED Posts: 7 Podling
    Any suggestions on what I can do to test if something is blocking the port?
  • DelakDelak REGISTERED Posts: 7 Podling
    Nope no luck. I cant find anything that would stop a port from opening. Other games that use ports work fine. Tried different ports, uninstall and reinstall, different users...

    It works fine on my laptop so I know it's not the router or anything.
  • SimbaSimba REGISTERED, Developers Posts: 74 Developer
    I am sorry that you are having so much trouble. I am beginning to suspect that it is failing for some other reason and "Port In Use" is a generic string we display regardless of what actually happened.

    Even if it's not a "port in use" issue I can't think of any other reason that port binding would fail. I will have to do some more investigation on our side to see if there is any other reason that error might pop up.
  • DelakDelak REGISTERED Posts: 7 Podling
    No worries this is what early access/alpha is all about. Just let me know if there are any logs you want me to post/send and/or settings you wish me to try.
  • SimbaSimba REGISTERED, Developers Posts: 74 Developer
    The library we use for networking is RakNet, and it seems to be throwing us a "Port In Use" regardless of how binding to the socket fails. The only reason I can find that these low-level networking calls would fail is either the port is actually in use, the application lacks permissions to create udp sockets, there is a lack of resources (buffers or available sockets), or there is an issue with the network subsystem on the computer.

    The issue could also be on our end. TUG could be trying to open two UDP sockets when you start a single player world and they are conflicting. This seems the most likely (since we've just about ruled all the others out), but we have heard of no one else having this issue, and can't reproduce it ourselves. If I understand correctly, even your other computer runs the game just fine.

    With all that being said, we are investigating a change that might help resolve this issue, but can't make any promises just yet.

    Thank you for being patient with us.
Sign In or Register to comment.