0.4.2063 Alpha Patch Notes

Auti0Auti0 REGISTERED Posts: 277
edited December 2013 in News & Updates
It is highly recommended that you force update for this patch. There was a lot of restructuring done and it is unknown what would happen with having all of the defunct files laying around.

Several new objects added to the game and biome generation

-Maple trees
-Winter maple tree
-Several shades of aspens
-Several variations of fruit tree
-Several varieties of mushroom
-Several variations of crystals
-Bamboo trees
-Fallen logs
-Wooden stump
-Vine resource
-Several types of wisps
-Apples, oranges, cherries, berries
-Updates to the bush plants
-Updates to trees across all biomes
-Crude pick
-Crude hammer
-Crude axe
-Shell scoop
-Club
-Updates to the textures and models for the gourd, gourd vines & boulders
-Crafting table versions for the rock, altar & stump
-Updating cave generation and object placements
-Biome specific lighting adjustments for day and night have been added across all biome generation
-Updated clouds and universal sky settings
-Added new biome The Valley, occurs between the mountains and snowcaps biomes.

Animation
Animation updates for first person and third person animations of running, walking & placing objects.Animations can now layer together. For example, running and placing/removing can now play at the same time.

Crafting
Recipes for some of the crude items have been added into the game along with the basic crafting system. Crafting requires a table plus the resource objects necessary to create a craft. Once all resources for the craft are placed on the appropriate table, pressing "G" will then activate the craft and produce a result.

Scripting
We have started migrating some basic functionality over to our scripting engine. The most interesting one is we are now doing all of the logic for remove and place block over to lua. The functions that are called exist in terrain.lua

Physics
Some objects start with physics enabled. Placing these objects will automatically cause them to react with other objects and the environment.Pressing "Y" while holding an object, throws the object. Pressing "P", toggles physics to be activated. All objects have a mass and friction to them and will react accordingly to these values. The controls for placing items has also changed. To toggle between placing or not you will need to press "TAB."

Networking & Third Person Camera
Networking is functional, but largely untested at the moment. On many games, physics is simulated by the server and the clients are told what to do, but we don't have the luxury of the server running physics because it would have to have the whole world loaded and simulated, which will be a bit much. We are going to work on some way to sync client simulations.
If you want to host a server you will need to forward the ports 6600 for TPC and 6601 for UDP.
In preparation for networking, we have enabled a third person camera angle to test animation and other issues with the Seedling. To toggle third person camera mode, press "Ctrl+3".

Items in Player Hands
A handful of items can now be held in the players hands. Along with these tools/weapons being held, when you are holding a specific tool it can only destroy certaintypes of terrain. This is the beginning phases of basic gameplay with terrain interaction.

Known Issues:
-Menu items are sorted in order than by grouping of type causing it to be out of order.
-Occasionally the game will crash during generation.
-Some players may experience not being able to see other playing during a multiplayer session
-Only one multiplayer session will work per game run. If you connect to a session then try to connect to another server you will crash.

Comments

  • PamcakesPamcakes REGISTERED Posts: 738
    Lovely!
    That's a really cool shirt you have on.
  • ProBeingNoobProBeingNoob REGISTERED Posts: 189 Seed
    Smexy!
    2.jpg
    BMOhn.gif9gF3P.gif
    Mind clicking those eggs?
  • Youngy798Youngy798 REGISTERED Posts: 905 Seed
    I hope Azzy makes a video about the seed :)
    Hello there! I am Youngy future owner of Plainhold (hopefully), go read the topic about Plainhold, and the Lemurian Empire, maybe also some of my other posts, like my mining suggestions! :)

    Bye!
  • mcmanusaurmcmanusaur REGISTERED Posts: 141
    Awesome, I really appreciate the comparatively huge variety of plants that you guys have been adding to the game, since I always thought Minecraft's selection was pretty limited. Ironically enough, I have just started working at a nursery, so maybe for once plants will finally become an area of interest for me in video games (I've never been too much into the herbalism and alchemy stuff before).
  • Youngy798Youngy798 REGISTERED Posts: 905 Seed
    I think they are making a really big effort to get the worlds right, there is no point having an amazing building and survival experience, when the world is boring and repetitive. Nerdkingdom obviously has their priorities set right and are making good progress :)
    Hello there! I am Youngy future owner of Plainhold (hopefully), go read the topic about Plainhold, and the Lemurian Empire, maybe also some of my other posts, like my mining suggestions! :)

    Bye!
  • InvisaMageInvisaMage REGISTERED Posts: 15 Seed
    I was able to play TUG fine. After the update though, windows says that it sops respoding then forces me to close it. I don't the the recomended grahpics card (working on getting a new one). I don't see how updateing could cause that after it was working fine. I have to play in a smaller resolution but still. I should atleast beable to load the game up.
    Any ideas?

    Thanks for your time
    -InvisaMage
  • Auti0Auti0 REGISTERED Posts: 277
    @Invisamage

    Could you please provide some information about your computer.
  • InvisaMageInvisaMage REGISTERED Posts: 15 Seed
    OS Name Microsoft Windows 7 Professional
    Version 6.1.7601 Service Pack 1 Build 7601
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name TRAVIS-PC
    System Manufacturer Dell Inc.
    System Model OptiPlex 3010
    System Type x64-based PC
    Processor Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz, 3201 Mhz, 4 Core(s), 4 Logical Processor(s)
    BIOS Version/Date Dell Inc. A10, 6/6/2013
    SMBIOS Version 2.7
    Windows Directory C:Windows
    System Directory C:Windowssystem32
    Boot Device DeviceHarddiskVolume1
    Locale United States
    Hardware Abstraction Layer Version = "6.1.7601.17514"
    User Name Travis-PCTravis
    Time Zone Central Standard Time
    Installed Physical Memory (RAM) 4.00 GB
    Total Physical Memory 3.90 GB
    Available Physical Memory 1.55 GB
    Total Virtual Memory 7.81 GB
    Available Virtual Memory 4.82 GB
    Page File Space 3.90 GB
    Page File C:pagefile.sys

    Here it is. Thanks for asking.
  • Auti0Auti0 REGISTERED Posts: 277
    Navigate to C:ProgramDataNerd KingdomTUGlibsx64(or x86 if you are running 32 bit windows) and copy the lua51.dll file that is in there. Then, paste that file in C:ProgramDataNerd KingdomTUG

    I am unsure what is causing this issue and I really don't like the current fix, but until I resolve why this is only happening on a handful of computers this will fix it for you.
  • SinnonSinnon REGISTERED Posts: 383 Seed
    Oh my! This is epic, testing it right now! :D
    Sintiacutetulo-1-1.png
    Enlist your faction in Seekers Order, sub-groups or alliances are not problem with the enlisting, since we are a not a clan, just a UN sistem of organization.
  • InvisaMageInvisaMage REGISTERED Posts: 15 Seed
    Thanks so much for your help. Fast too. :)
  • JoeJoe REGISTERED Posts: 264 Seed
    Magical glowy leaves are back!! :mrgreen:
  • VisigothVisigoth REGISTERED Posts: 268 Seed
    man I love the art on the new launcher, it looks awesome :D but the extra highlight on the bottom looks out of place @[email protected]
    2mrSQTP.png
    tqJH8d0.png L8gIJPq.png HS9Ak7Z.png bJiq4Rv.png
  • AzzyAzzy REGISTERED Posts: 182
    anyone else getting really bad framerates ?
  • TeknonickTeknonick REGISTERED Posts: 166 Seed
    Is this a secret? I was running around, and I had a blue gem! YAY! But get this. The Player Model has a red gem. O.o.

    lol. Anyway, keep up the GREAT work! Oh, and I love the running, it's so funny! XD. Maybe you could save that animation (If you plan to remove it) and use it later for sprinting when your character's tired... or running over a rope-bridge ETC.... Would be cool :3
    The mix between the Adventurer and the Trapper yields the Tracker. Living in humble homes to help those in need. Always looking for the right coin, yet never theft is in their eyes.
    21.jpg
    20.jpg
  • SparkSpark REGISTERED Posts: 12
    Love the new update. Awesome job as always!
  • Sorrox BluefieldSorrox Bluefield REGISTERED Posts: 70
    This new Update Is amazing So far I love the way the biomes are looking!
  • ObituaryPhoenixObituaryPhoenix REGISTERED Posts: 1
    i tried to update to the newest patch and it says that i dont have access or something and i dont know how to get the update now!!!
  • SigilSigil REGISTERED Posts: 678 Developer
    You're not the only one. I hear they're messing around with the code. I'm sure they'll have it all back in order soon.
  • Auti0Auti0 REGISTERED Posts: 277
    A temp fix has been put in place for the people being unable to update due to a "forbidden" error.
  • LeifLeif REGISTERED Posts: 361 Seed
    An update in time for my birthday! Thanks for all the hard work guys :)
    otViQlH.png
  • Ashen44Ashen44 REGISTERED Posts: 207 Seed
    This is proof that they're listening to us! Quite a few of the new features have been suggested on the forums! And by quite a few I mean the beginning of block physics they have now.

    (writes this while listening to 'Take Back the Night')
    The pessimist sees the glass as half empty. The optimist sees it half full. The engineer sees the glass as twice as big as it needs to be.
  • PianoMastR64PianoMastR64 REGISTERED Posts: 2
    TUG will not update to this patch version. It goes through the whole update process and makes it seem as though it actually updated, but when I launch the game it show me that it's still on version 0.3.1292.

    I double click the TUG launcher, and it opens. I enter my password correctly. I click "Update". A window pops up saying "New version of the launcher found. Launcher will now update." I click "OK". The launcher says "Downloading: Launcher update..." When it's done, I click "PLAY". When the game has finished launching, it reads in the bottom right corner "TUG - Early Alpha v0.3.1292 64-bit". I've attempted to update about 4 times, and it's still not on the latest version. I'm going to assume the latest version available for download is version 0.4.2063. Why is TUG pretending to update?

    (I am not 100% sure where I can find the version number of the latest patch available for download at any given moment. Also, it would be really helpful if Leif included the patch version in the "Patch History" for every new patch that is available.)
  • TestamentofTestamentof REGISTERED Posts: 1,234 Seed
    PianoMastR64, This is an excellent step by step that would fit wonderfully in the support form on the contact page!

    I suggest redownloading the launcher form the website, and when it's done installing the new launcher, click the little cog button next to the update button and make sure "FORCE UPDATE" is ticked, then press update!
    The Machine is on....

    6.jpg

    otViQlH.png
  • Auti0Auti0 REGISTERED Posts: 277
    PianoMastR64

    It appears you have a version of the launcher that was unable to successfully self-update. Please head to your accounts page and download the latest version there.
  • SinnonSinnon REGISTERED Posts: 383 Seed
    Awww yeah! Craftin', going totally testing it right now!
    Sintiacutetulo-1-1.png
    Enlist your faction in Seekers Order, sub-groups or alliances are not problem with the enlisting, since we are a not a clan, just a UN sistem of organization.
  • PianoMastR64PianoMastR64 REGISTERED Posts: 2
    Thanks. I re-downloaded the launcher and did a force update. It works now. Thanks.
Sign In or Register to comment.