Select Graphics Card?

farigissfarigiss REGISTERED Posts: 2 Podling
When I'm in game and press F2 it shows the GPU being used is Intel HD 4000 onboard graphics.
I do have a AMD Radeon HD 7970 set up as my primary graphics device. And every other game I've played uses that card by default. Is there any way I can force TUG to use my 7970? I use the onboard for my second monitor so I'd rather not disable it.

Comments

  • ShadeeShadee REGISTERED, ADMINISTRATORS, Moderator, Developers Posts: 402 Site Admin
    edited June 2015
    Hi @farigiss! You should be able to create a profile in your Radeon's software to make a program use a specific graphics card when it's run.

    The following page shows where to find these settings. It has this info for a bunch of different types of cards though, so you'll have to scroll down to the "ATI/AMD Radeon Cards" one: https://support.serato.com/hc/en-us/articles/202305784-Changing-graphics-card-settings-to-use-your-dedicated-GPU-on-a-Windows-computer-
    -Dee.
  • farigissfarigiss REGISTERED Posts: 2 Podling
    edited June 2015
    Unfortunately I don't have the settings for switchable graphics. It seems this is a feature that exists only laptops to extend battery life.
    Other games correctly choose my discrete graphics card as far as I can tell. Perhaps this is something that needs to be fixed within the game.


    I used GPU-Z and found out that launching TUG brings the (AMD) GPU load from 0% to 100%. So, false alarm.
    However it's a mystery why the F2 debug screen shows the onboard GPU because it isn't being used by the game.





  • ShadeeShadee REGISTERED, ADMINISTRATORS, Moderator, Developers Posts: 402 Site Admin
    Hey @farigiss, I was just reminded of a known in-game display bug. If your AMD Radeon HD 7970 is set up as your primary card then TUG should be using that card. For some systems, the F2 menu lists the wrong card. It's something we are working on fixing.
    -Dee.
Sign In or Register to comment.